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INTRODUCTION & NEWS
Dear user,
Thank you for choosing soft Xpansion's Perfect PDF 12 family! The product family offers a wide
range of options for creating, converting and editing the content or changing the layout of PDF,
PDF/A and XPS files. In addition, its integration into widespread Windows applications (Windows
Explorer, Microsoft Office) enables the convenient and efficient use of the PDF format in day-today work with documents.

New Approaches in Perfect PDF 12
Perfect PDF 12 is innovative and modern compared to the previous versions in several ways:
1. On the one hand, the software was completely redeveloped, so it has a new user
interface and meets current requirements for user-friendly software with a wide range of
functions.
2. In the new version, the program now also supports touch operations and using a pen.
Both allow the convenient use of Perfect PDF 12 on tablets.
3. In addition, Perfect PDF 12 offers payment plans (subscription and one-time payment)
and product models (editions, packages and configurator) that let you flexibly determine
which features you need and how much you will pay:


Two payment plans: either an annual subscription or a one-time payment



Three product models (the range of functions can change over time, you can find out
the current status on the respective product pages on the Internet): broadly based
editions (Office, Premium, Business), which offer a large number of different
functions combined in one product; smaller packages with a few, focused functions
that handle special tasks in a targeted manner (e.g. PDF editor for editing files); and
the configurator that lets you select your product functions very individually
according to your needs



The editions can also be expanded with optional functions and additional
functions may be subsequently offered after the initial release of Perfect PDF 12

4. The optional personal soft Xpansion customer account also provides a variety of
options for online management of your Perfect PDF software in a single place. For
example, you can use your account to download the latest program version or link your
product key to the associated product.

The Central Program Functions
The program functions can be divided into basic and business functions. The most important
functions are listed below:*
6

INTRODUCTION & NEWS

1) Basic functions


PDF Reader: Display, read, and navigate around PDF documents (scroll, use links, etc.)



Virtual printer: create new PDF documents from any printable application or from
printable files



Create PDFs from text, images (PNG, JPEG, GIF etc.), vector graphics (SVG & EMF),
and scans



Create PDFs from Word, Excel, and PowerPoint files



Import PDFs from Outlook emails and objects, including email attachments



PDF editor: edit page content (text, images, vector graphics)



Combine and split PDF files



Create PDFs from individual HTML files



Convert between PDF and XPS formats



Export plain text and pages as raster (bitmap) graphics



Create encrypted and password-protected PDFs (all supported standard PDF methods).



Digital signing of PDF files, optionally with a simple time stamp (system time of the
computer)



Page management (insert, delete, move, resize, rotate, etc.)



Edit page design (letterheads, backgrounds, headers and footers, watermarks).



Edit navigation options in the document (links, bookmarks, table of contents)



Add and edit comments: highlight and redact text, create text boxes and sticky notes,
stamps and watermarks, pen, shape, media, and 3D objects



Embed files and add attachments as comments



Create and edit interactive PDF forms

2) Business functions


Optimize PDFs (such as for the internet), layer management



Convert PDFs to PDF/A-1, 2, 3, 4



PDF events, actions, and JavaScript editor



Use several PDF signatures (compared to basic function with only one signature),
PAdES signatures (B, T, LT and LTA level), document time stamps from trustworthy
service providers



Create PDFs from HTML structures (several HTML pages; compared to basic function
with PDFs only from individual HTML pages, not from multi-page structures)
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Import eBook files (convert to PDF)



You can also use the program via a remote desktop connection

Perfect PDF 12 is based on PDF Xpansion technology already used in over 1,000,000 installed
applications worldwide.
*The total range of functions available can change over time. You can find out the current
status in the online product overview.
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Payment Plans & License Models
License models
At the time of the initial release, the following license models were offered for Perfect PDF 12:


Freeware license for Perfect PDF 12 Reader. The program for viewing PDF, PDF/A, XPS,
Text, EPUB and FB2 files is completely free. It can be installed and used on any number of
computers.



The single-user license (valid for the Business Edition, for the packages, and for the
configurator) grants the right to install, activate, and use the product on exactly one PC
workstation or device (and a single operating system). Before further activation can take
place, the program must be uninstalled on the first workstation/device.
If the program is to be used on several computers without a remote desktop connection
within the framework of single-user licenses, the number of licenses required can be
purchased in the soft Xpansion web shop.



The two-user license for two PC workstations or devices, valid for the Premium and Office
Edition



The multi-user license. Details of the multi-user license can be found on the product
website.

Payment plans: subscription or one-time payment
There are two simple payment plans for the single-user and two-user licenses: either you
purchase and pay for the software as a subscription for one year or you make a one-time
payment and thus acquire the right to use the software for an unlimited time period.
The multi-user license (MUL), on the other hand, can only be licensed as an annual subscription.

Updates & Support
You can carry out version updates directly from the program. File > Product, then follow the
instructions under Program Update.
Notes:
1. An update is only possible if you have created a soft Xpansion account and connected the
product to the account. See the Product section for more information.
2. In order to make sure that the update process runs correctly each time, always restart your PC
after each update.
If you have agreed to receive newsletters, we will send you email to receive news. Such
newsletter may also include information on updates if there are any.
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Technical support is available after purchase. You can currently contact us in the following
ways (changes are possible and will be announced at the appropriate place):
1. Email: support@soft-xpansion.com
2. Telephone: +49 (0)234 588 01265 (Mon - Fri, 9:00 a.m. - 5:00 p.m. CET). Please check
that the phone number is up-to-date on the soft Xpansion website.
For all support requests, please provide us with your product key. It is best to make your
request via your account, which you can optionally create on the website. The key helps us
determine your exact product version. Additional information such as screenshots, files (file
created by the program and/or original file), error messages, what you were doing with the
program when the issue occurred, and, if applicable, a description of what you expect the
program to have done at that point are recommended and will speed up the processing of your
request.

About This Guide – the Editions
This guide describes the functionality of Perfect PDF 12 Business Edition. The Business Edition
has the largest range of functions in the family. The other editions and, of course, also the
smaller packages mentioned at the beginning of the introduction, as well as the collections of
functions you select with the configurator, will have fewer functions and properties, so that not
all sections and contents of this manual may be relevant for you.
The Perfect PDF 12 Reader (the Reader Edition) forms the basic functionality for all other
editions. Perfect PDF Reader is free to use and allows you to read PDF documents, but not
modify them.
The table of functions on the Perfect PDF 12 website lists the main differences among the
editions. This overview is intended to help you find your way around these instructions. Since it
is not possible to list and assign all functions in detail without giving up clarity and
comprehensibility, the table is structured in exactly the same way as the configurator. This means
that the overview is based on the separately available individual functions of Perfect PDF 12.

Tutorials for Perfect PDF 12
Several tutorials are available on the soft Xpansion website in the "Support/Technical Support"
section. They explain the basic procedure when using selected, essential program functions. For
example, the following topics are covered: PDF editor, protect PDF, digital signature, convert to
PDF, split PDF files, delete PDF page, create PDF form.
In this guide, each tutorial is mentioned separately together with the description of the
respective program function; the online help additionally includes a direct link to the respective
tutorial on the website.
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INSTALLATION AND ACTIVATION
Before installing Perfect PDF 12, please make sure your computer meets the system
requirements. This will ensure that the installation can be carried out correctly and that the
program's capabilities are being optimally used.

Installation
In order to install and use Perfect PDF 12, please do the following:
1) If you have purchased a CD/DVD, please insert it into your CD/DVD drive. If the Autorun
function is activated for the drive, the installation will start automatically after insertion. If the
installation does not start automatically, double-click the "setup.exe" file on the CD/DVD.
2) If you purchased a downloadable version, open Windows Explorer and double-click the zip file
you downloaded. Unzip all of the files to a folder on your computer; only then should you
double-click the "setup.exe" file in that folder.
3) Before installing, make sure you have administrator rights in Windows. A special message will
appear asking if you would like to allow the installer to make changes to your system. In other
words, install Perfect PDF 12. You must grant this permission or ask your system administrator
to do so. It may be necessary to enter a password.
4) In the first installation window, select the language you want to install the program in.
5) Carefully note the installation instructions. Note that the installer will scan your computer for
the presence of all necessary components. For example, if the "Microsoft Visual C++ 2015-2019
Redistributable Package" is missing, it will be installed automatically, and a corresponding
message displayed. If the automatic installation of this component cannot take place for some
reason, you can also set it up manually: Double-click on the "VC_redist.x64.exe" file (if you are
using a 64-bit computer) or on "VC_redist.x86.exe (for 32-bit computers), which are supplied on
CD/DVD or in the installation files folder.
6) Specify whether the program should be installed in the default directory or in a different
folder.
7) Choose the features you want to install: the virtual printer (installed by default) and the
options for integration with standard applications (Windows Explorer and Microsoft Office). To
do this, click in the check boxes in front of the options.
8) At the end of the installation or when you first launch the program start, you must activate
the product for use. After activation, you can use Perfect PDF 12 immediately.
To uninstall Perfect PDF 12, open the "Settings" in Windows 10, then "Apps" and click on
soft Xpansion Perfect PDF 12 in the "Apps and Features" group. To remove the program
from your PC, click on "Uninstall" and follow the instructions that appear. In other Windows
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versions, the uninstallation may require different commands and may have to be done via the
Windows Control Panel, for example.

Activation
Important note: The different, older purchased versions of the Perfect PDF software (up to and
including version 11) had to be activated with a product key and installed separately. There are
significant changes in this regard with Perfect PDF 12: On the one hand, with the exception of
the free Reader and the trial version, a product key must still be entered before the
corresponding program can be used. What is new is that for Perfect PDF 12 all product versions
require activation, including the test and Reader versions. The different editions and versions of
Perfect PDF 12 can now also be unlocked from a single installed program package. Read the
details in the following section.
At the end of the installation and/or when you launch the program for the very first time, the
Perfect PDF 12 activation dialog will open automatically:

Important note: Activation, even as a test version or Reader, requires administrator rights. The
program must be launched in "administrator" mode.
Use one of the five buttons on the left to read the related information on the right and follow
the different instructions to select one of the available unlock options.
For example, click on the second button from the top to unlock the Office, Premium or Business
edition with the product key you've purchased. Enter it and follow the further instructions:
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If you want to change the activation later, open the dialog in the program menu via File >
Product > Manage product activation.
If you have purchased a Perfect PDF 12 single-user license, the product will be activated for
a single workstation or device:
The single-user license grants you the right to use the product on a single operating system on a
single workstation/device. To install and activate it on another device, the software must first be
uninstalled on the previous workstation, computer or device.
The simultaneous activation of several installed copies or using the program at several
workstations within your local company network with a single-user license is not permitted and
also not possible. Please purchase several single-user licenses or a multi-user license for such
applications. With the multi-user license, Perfect PDF 12 can also be used in a multi-session
environment provided by remote desktop services (RDS, formerly known as terminal server).
Details of the multi-user license can be found on the product website.
If the product was not activated during installation, you have the option of activating it later
when you start the program for the first time.
Activation can take place in two alternative ways: after entering the product key and clicking on
the "Request activation" button automatically (online; recommended option) or by sending an
email in order to receive an activation file (ending with *.auth). You would then load this file
into the program with “Select activation file." With this option, you will also need to enter the
product key.
After successful activation, a corresponding message will be displayed and you can exit the
activation dialog by clicking on "Close." Your computer must then be restarted to complete the
installation.

Activation on another Computer/Device
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If you want to use Perfect PDF 12 on a different computer or device than the one(s) where it
was already activated, please first uninstall the program from the original computer/device(s),
then install it on the new one and repeat the activation there.

System Requirements
In order to install and start Perfect PDF 12, your computer must meet certain requirements. The
current system requirements can be found on the soft Xpansion website.
Note: Windows, Microsoft Office and other program versions developed after the release of
Perfect PDF 12 cannot be guaranteed to integrate correctly. It is therefore possible that PDF
creation will not initially work in such versions, but only after Perfect PDF 12 is updated.

Starting the Program & Installed Components
In Windows 10, the installation will place a Perfect PDF 12 icon alphabetically in the
Windows Start menu under P. Click on the icon to start the main program. Here you
can load or create a PDF document and use the program's extensive options to edit
PDF files.
If you specified this during installation (see point 7 there), not only the main program will be set
up: In Windows Explorer, you will also find different Perfect PDF 12 commands for working
with different files under the file context menu. In this case, in the Microsoft applications Word,
Excel, PowerPoint, and Outlook, an additional “Perfect PDF 12” group is added to the ribbon.
Note: If, after installing Perfect PDF 12, you want to change how it is integrated into Microsoft
Office or in Windows Explorer, click on Settings > Apps and Features > soft Xpansion Perfect
PDF 12 > "Change." Then the installer starts and the dialog for specifying the integration
settings will display.
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PDF DOCUMENT
The main objects and content that a PDF document can contain and/or form the structure of a
PDF are presented in the following subsections of this chapter. Also, in the chapter you will learn
where to find the commands for working with them in Perfect PDF 12.

Brief Introduction to the PDF Format
A PDF document is a document saved in Portable Document Format (PDF) and has the file
extension "PDF." This format was presented in 1993 by Adobe Systems as an open standard for
exchanging electronic documents. It allows documents to be shared independent of the
hardware and software used. Each PDF file includes a document and a full description of the
page's content in a fixed layout, including text, fonts, images, and other information needed to
view it.
Between 1993 and 2006, Adobe Systems actively developed the PDF format and published
seven new versions up to version 1.7. It has since come into use around the world in the most
diverse electronic document management applications and is now the de facto standard for
many.
At the beginning of 2007, Adobe Systems then applied to the International Organization for
Standardization (ISO) to register the PDF format as an ISO standard. In July 2008, the ISO 320001 standard based on PDF version 1.7 was released and published. Since then, PDF has also been
registered as the standard de jure. PDF 2.0 (ISO 32000-2) was published in July 2017 and the
second edition of the current PDF specifications have been available since December 2020 (ISO
32000-2:2020).
PDF files contain the document data in binary form, so viewing the files requires a special PDF
Reader. In order to create and save a PDF file, a special PDF creation program is also required.
And to edit PDF files, a PDF editing program is required. Perfect PDF 12 combines the functions
for these three task areas into a single program that allows users to perform all tasks related to
PDF documents.
In the structure of a PDF document, there are a variety of interrelated objects, including pages,
comments, images, and fonts. If you use Perfect PDF 12, you do not need to know too much
about the specifics of PDFs in order to edit them. Perfect PDF 12 ensures their internal integrity
and correctness. At the same time, it is a powerful tool for professional users working with PDF
files.

Document Properties
A PDF document has a set of properties that define the whole document. This would typically
include:
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PDF file: File properties define the technical characteristics in which a PDF document is
saved as a file: PDF version and optimization for use on the internet



Document description: creation and modification dates, title, author, subject,
keywords, and how the document was created



Custom properties: any textual descriptions added by a document author or editor.
These must have unique names that are not identical to the standard properties from
the description



Metadata: additional data in XML format



Security settings (document protection)



Digital signatures

The Perfect PDF 12 document properties features are explained in the Menu: Document section.

Security Settings (Protection and Rights)
This is where the rules for protecting the PDF document and access to its contents are set:
encryption method and degree of encryption (algorithm, key length), owner and user
passwords, access rights.
The owner password should be assigned to users who will need to access the document without
restrictions, including the ability to change rights, encryption, and passwords.
The user password is intended for users who can have access to the document to the extent set
by its owner (often the author). A user can open a document protected with a user password,
but cannot set or change any rights, encryption, or passwords. Those who do not know the user
password cannot open the document. If the document has been encrypted but no user
password has been set, any user can open and edit the document without having to enter a
password. However, their access rights are restricted to the extent specified by the owner.
The following access rights can be granted or denied for the PDF format in order to control how
users interact with the document: printing, copying content, making changes to the document
(including filling out form fields, editing structure or content, adding, removing, changing
comments).
The Perfect PDF 12 security settings features are explained in the Protection & Rights section.

Metadata
Metadata describes the characteristics or properties of a document and extends basic document
properties. It allows users and applications to work more efficiently with documents. Metadata
makes documents easier to use in applications, even if those applications do not know the
original file format of the document. Metadata can also significantly increase the value of
collaborating on documents as part of production processes. For example, an image file may
16
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contain metadata such as a working title, description, thumbnail or intellectual property
information.
In order for different applications to actually be able to use metadata, there must be a common
standard that all applications understand. The Extensible Metadata Platform (XMP) provides such
a standard. XMP-encoded and XML-formatted data supports a wide variety of workflows and
tool environments. Localization is possible and Unicode is supported.
The Perfect PDF 12 metadata features are explained in the Metadata section.

Digital Signatures
This includes the commands for adding signatures and signing documents, viewing existing
signatures, adding timestamps, and deleting signatures.
Digital signatures are used to authenticate PDF documents using computer encryption methods.
They help ensure the following:


Authentication: to ensure that the signer of a document is actually who they say they are.



Integrity: to ensure that the content of the document has not been altered or tampered with
since it was signed.



Indisputability: to ensure that the origin of the signed document can be proven to all parties
involved and to prevent the signer from later denying that they were involved with the
document.

To achieve these three purposes, the signatory has to digitally sign the PDF document using a
certificate. A certificate certifies the identity of the signatory and proves the authenticity of the
signature. Valid certificates are issued by a certification service provider and, much like a driver's
license, can expire and be revoked.
To check whether the three requirements above have been met, the PDF program must provide
evidence that the signature meets the following criteria:


The digital signature is valid



The certificate associated with the digital signature is current (not expired)



The person or organization signing the document is trustworthy



The certificate associated with the digital signature was issued by a reputable, trustworthy
certification service provider

Trustworthiness here means trusting the individual or organization for whom the certificate was
issued because the issuer of the certificate, usually a certification service provider, is already
trusted.
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A certification service provider is a commercial organization that issues digital certificates (digital
identifiers or identifiers), keeps track of who has been issued which certificate, signs certificates
to prove their validity, and keeps track of which certificates have been revoked or expired. In
many companies, digital identifiers are assigned by the system administrator. To obtain an
identifier for private use, you must contact a certification service provider.
Digital signatures are created by calculating a numerical value that is a summary of all the data in
the document. The numerical value is stored in the PDF file. When checking the signature, the
numerical value is recalculated and compared with the value stored in the PDF file. If both
numerical values are the same, the document has not been changed. Differences in values
indicate changes have occurred since the document was signed.
Optionally, each signature can also be provided with a time stamp. In the case of a signature
marked with a time stamp, an external body verifies exactly when the file was signed. In this way
it can be proven that the signed document version and the signature existed at the same time. A
trusted timestamp is created by a trusted third-party timestamp provider. If the timestamp
provider can be classified as trustworthy, this constitutes verification that the document was
signed after the time indicated by the timestamp. Timestamping your document does not
compromise the confidentiality of your document; only a summary of the signature is sent to the
timestamp provider.
A decision often has to be made by several people. Multiple signatures are then required for a
document to be finalized. This results in one signature after another. This means that the first
signatory signs the document, and then the second signs the document and signs off on the first
signature. Only when the last signature is attached is the document considered to be definitively
signed. The PDF format allows such consecutive multiple signatures, but each new signature
must be executed as an incremental update (new revision of the document).
Each signature must be associated with a signature field in the PDF document. An existing
empty field can be used for this, or a new field object can be inserted. Also, a signature field can
optionally be associated with a visible, graphical representation of the signature placed on a
page.
The Perfect PDF 12 digital signature features are explained in the Digital Signatures section.

Pages
Document pages are objects that represent the document content. Page content is associated
with each page and is not dynamically transferred from one page to another. The pages can be
read and edited. Editing includes:


Editing page content in a PDF editor



Page management: adding, deleting or rotating pages as well as changing their order,
size, or orientation



Printing pages
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Extracting and exporting pages

Layers
Layers are optional visible content in a PDF file that can represent a part of the page content as a
block of graphic elements. Such a block can alternatively be displayed or hidden by the user or
the author of a document. This feature is useful in such applications as CAD drawings, multilayer artwork, maps or multilingual documents.
A layer is a named object consisting of a collection of optional blocks of content that can be
displayed or hidden by the user in the PDF Reader. The graphics that belong to such a group can
be distributed on different pages within the document.
The Perfect PDF 12 Layers features are explained in the Layers section.

Annotations
As already mentioned, the basic principle of the PDF format is that documents in this format
should not be extensively modified. Because of this, however, there are extensive options
available for commenting on or annotating the content of PDF files. Annotation types include
sticky notes, text highlighting, stamps, watermarks, text boxes, shapes, pen, audio, video and 3D illustrations.
Each annotation object is linked to a document page. Annotations are typically represented by
an icon or graphic element on the associated page and their content is displayed in a rectangular
area (annotation box). Actual page content (sequence of graphic and textual elements) and
annotation content are two independent structures. From a technical point of view, their
elements each have their own nature and coexist. When displayed on the screen or printed out
on paper, the page content is covered by the overlying annotation objects. As a rule, PDF
programs offer the option of optionally displaying and/or printing annotations on the pages,
depending on their type.
Almost all annotation types are interactive: users can manipulate the annotation object to adapt
the display to their needs and preferences. These changes leave the actual PDF document
untouched, but only change the appearance of the annotation in the program's display window.
The Perfect PDF 12 annotation features are explained in the Annotations section.

Form Fields
PDF documents can contain form fields. A form field is an object into which field data is placed
and stored. Depending on the type, the field has different properties. Each field also has a
unique name throughout the document.
Possible types include text field, radio button, check box, combo box, selection list, button,
barcode field, and signature field.
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The Perfect PDF 12 features related to forms and their fields are explained in the Forms section.

Events, Actions and Scripts
When you click a link on a PDF page (= event), then the PDF Reader displays a document or web
page referenced by the link (= action). More specifically, this is the default action when you
release the left mouse button. The event triggers the "Go to Page" action, where the specific
page number or web address is defined.
In addition to the event/action relationship just mentioned, a whole range of events can be
linked to actions in PDF documents. A specific event would then automatically trigger an action
previously associated with it. An event is either a change in the status of objects in the PDF
document or an action by the user.
Events can be defined for the following objects:


the document as a whole



individual pages of the document



form fields



annotations

These Perfect PDF 12 features are explained in the Events, actions, and scripts section.

Fonts
Each character of text in computer typography or PDF documents is an abstract symbol and a
character is a specific graphic representation of that character. Characters are grouped into
fonts.
A font file defines characters for a specific character set. Each character is a small program
written in a language for a specific purpose, such as the TrueType or Type 1 font formats. This
language is understood by the PDF program and used to create text characters.
A PDF document contains a font as an object that contains the font type, the PostScript name,
and information about how to provide a substitute font from the system font pool if the font is
not embedded in the PDF file.
Optionally, the character data can be inserted into the PDF file as an object (embedded font).
Although this makes the PDF file larger, it guarantees the correct text display regardless of the
computer used. However, this data does not include the entire script, but only a subset of
characters, namely those used in the document.
If the font is not embedded, the letters and characters may not appear correctly. Or, for
example, in Arabic or Asian languages that require special fonts, no letters and characters might
be displayed at all.
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The Perfect PDF 12 font features are explained in the Fonts section.

Images
The PDF format allows the use of raster images (bitmaps) as graphic elements of the page
content, as well as for the representation of annotation objects, thumbnail pages, and possibly
other elements of the PDF document.
Each bitmap object has the following properties: width (number of points or pixels in a line),
height (number of lines in the bitmap), color depth (number of available colors per pixel monochrome, palette or true color), color space (abstract mathematical model for describing the
digital colors - either the RGB, CYMK, greyscale or some other model), and method of data
compression (compression algorithm for bitmap data). All the properties mentioned affect the
image quality and the size of the PDF file: a higher quality also means a larger PDF file. To reduce
the file size, change the data compression method, image size, or other image properties as long
as the quality is good enough for you.
The images used should always be embedded in the PDF file.
The Perfect PDF 12 features related to images in PDF documents are explained in the Perfect PDF
12 section.

Embedded Files
In addition to the main PDF document, a PDF file can contain any number of embedded files.
The data from these files is stored in a similar way to a ZIP file. The embedded files are usually
also PDF files. For example, a user manual that consists of several chapters can contain these
chapters as separate PDF documents. In addition to PDFs, the embedded files can also have any
other format.
Perfect PDF 12's embedded file features are explained in the Files section.

Outline/Table of Contents
PDF documents also optionally contain an outline/table of contents and bookmarks. In this way,
users can move through the document and go directly from one place in the document to
another without having to scroll through the document page-by-page with the mouse or
manually enter page numbers or terms in search dialogs. The outline has a hierarchical tree
structure and acts as the table of contents for the document, i.e., it structures the content using
the headings and subheadings used.
The related Perfect PDF 12 features are explained in the Menu: Navigation section.

References (Links and Bookmarks)
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Like any other modern electronic document format, PDF allows areas within a document to be
linked together by referencing a page or specific coordinates on the page. Technically, links are a
special form of annotation. However, unlike the other comments, links do not have a visible icon
or graphic element representing them. An area of the page is defined for placement of the link
and this overlays a content element, for example as blue underlined text or as an image. The link
refers to a page or a range of pages in the same document, an e-mail address or a web address
as the target.
If there are many references to the same page or to the same page range in a document, you
can also define bookmarks in PDF files. These are comparable to bookmarks in Microsoft Word.
Such a target object has a unique name throughout the document and is linked to a rectangular
area on the PDF page, for example a formula or specific word in the text. All links in the PDF
document that reference this object then use the same name. Bookmarks are more accurate and
clearer than links based on page numbers.
The related Perfect PDF 12 features are explained in the Menu: Navigation section.

PDF/A Format for Long-Term Archiving
PDF/A has undoubtedly established itself as the standard for the long-term archiving of
electronic documents. The format was published as ISO Standard 19005 in September 2005.
This standard specifies a file format based on PDF (PDF version 1.4). However, this "simple" PDF
format does not guarantee reproducibility over a long period of time or complete independence
from software and the output device. To ensure compliance with both principles, certain
properties of the PDF specification needed to be more precisely defined and limited. Among
other things, PDF/A conformity requires that all fonts be embedded in the document and that
encryption of the document, transparent graphics, and the playback of audio and video are not
permitted.
Perfect PDF 12 offers the option of creating PDF/A-1, 2, 3 and 4 documents. This significantly
expands the scope of the created PDF/A files: with the PDF/A-2 format, transparent annotations
(e.g. highlights in presentations) can also remain in PDFs, JPEG2000 is available as a lossless
compression format (e.g. for photographs and other image material), PDF/A files can be
embedded in PDF/A, and layers can be switched on or off (useful in CAD drawings). PDF/A-3
also allows any files to be embedded in PDF/A. Original documents can also be stored in PDF/A-3
files. For example, PDF/A-3 thus enables electronic invoices to be stored in PDF/A format,
whereby both the data in XML format that can be read by computer software and the
electronically archivable PDF version of the invoice can be stored in the file. PDF/A-4 is based on
the PDF 2.0 standard. On the one hand, the use of PDF/A-4 should ensure a static visual
representation of page-based electronic documents over time, while also allowing the use of
interactive (non-static) content as an embedded file.
The Perfect PDF 12 features related to PDF/A are explained in the Export section because, as
already mentioned, the program allows the conversion of PDF to PDF/A formats (PDF/A-1 to
PDF/A-4).
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CREATING PDF FILES WITH THE PDF
PRINTER
The easiest and most widely used method of converting
electronic documents to PDF is to use a PDF printer: in
any application that can print documents, this is done
using a so-called PDF printer or virtual printer. This
printer is the central component of most PDF creation
programs.

Virtual Printer
The Perfect PDF 12 virtual printer will be set up automatically in Windows 10 under Settings >
Devices > Printers and Scanners, unless you have actively deselected this at the beginning of the
Perfect PDF 12 installation .With older operating system versions, you may find it elsewhere
after installation, for example in the Windows Control Panel.
The difference between a virtual printer and a physical printer is that the virtual printer is just
software (driver and related properties), while the physical printer consists of a driver and a
hardware device.
Perfect PDF 12's virtual printer outputs a specified number of pages in EMF format as the
result of a print job. These EMF files are then further processed and converted into PDF pages.
In Windows, a virtual printer can be managed just like a physical printer. For this reason, it can
also be used without any problems from any printable application.

Print From any Application
With the Perfect PDF 12 virtual printer, you can print electronic documents or data from any
application that has a printing function.
In the Print dialog of the application from which you want to create a PDF file, simply select the
Perfect PDF 12 printer from the list of available printers. The PDF printer software receives the
print output from the application and converts it into a PDF document. After that, this document
can be automatically saved as a PDF file. Or it can be loaded into the Perfect PDF program and
then viewed or edited there.

Printer Settings
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Like any other printer, the Perfect PDF 12 virtual printer has a dialog in which you can view and
change the properties (in Perfect PDF 12 the properties of the PDF files to be created) and the
settings of the printer.
The dialog displays and defines the PDF and print settings used by the PDF printer and the
Perfect PDF program when processing print jobs and converting files or data into PDF
documents.
You can get the printer settings dialog in Windows Settings > Printers & Scanners by clicking on
the Perfect PDF 12 printer or directly from the print dialog in another application.

Print Jobs
The category on the left tab contains only the properties for the PDF printer, not the defaults for
converting files to PDF format.

Preferred Paper Format
The paper size to be used is specified here. You can also choose between portrait and landscape
format.

Preferences for Processing Print Jobs
This is where the PDF printer is told how the print jobs are to be processed. The radio buttons
offer four mutually exclusive alternatives:
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after the print job (i.e. to create a PDF) has been submitted, the main program is opened
automatically with the PDF document



a PDF file is created, and users specify the individual storage location in a "Save as"
dialog



a PDF file is created, and users define a fixed storage folder in advance



the print-to-PDF job is processed later

The checkbox "Save raw print job data for further editing" at the bottom of the dialog
determines whether a print job is saved as a temporary file. If the box is checked, the print jobs
can be loaded into the Perfect PDF 12 program later for further editing. You can select later
editing of a print-to-pdf job only if this option is activated. Activate it very sparingly and only,
when necessary, since the temporary files can take up a significant amount of disk space.

PDF
In the category on the right tab, the properties of the PDF documents to be created are defined.
The category contains three groups.
Note: To make your entries or changes in the groups, click in the right-hand column below
"Setting or value" in the desired line so that a cursor or a colored arrow pointing downwards
becomes visible as a symbol for a selection list. For example, under Encryption, you can choose
from several available encryption methods after clicking on the arrow.
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General Properties
The general properties of a PDF file are entered here: title, subject, author, source application,
and keywords. If an original file (e.g. from Microsoft Word or another format) provides similar
general information and this is specified in the Import Settings, it will be imported.

Security Features
The security features depend on how the document is encrypted. If "Not encrypted" is selected,
no further properties are available.
After an encryption method has been selected, the following properties can be specified:


"Require user password (to open):" if a password has been set here, it must be entered
when opening an encrypted document in a PDF viewer.



"Owner password (for editing):" the password assigned here will have to be entered if
editing the document is to be allowed; this includes changing the security settings.
"Access rights" can be assigned or blocked for all encryption methods. They determine what
actions users can perform with a PDF file: for example, print, copy content, edit.

Only the owner of a document can subsequently change the security settings of encrypted files.
Owners are any users with the owner password.

PDF File
This defines the settings with which a PDF document is to be saved as a file. For example, enter
the PDF version here (versions PDF 1.x or 2.0 and various PDF/A sub formats) and determine
whether fonts should be embedded, how existing images should be compressed, and how the
PDF file should be displayed in the PDF viewer.
In the introduction to the PDF Document chapter, you will learn some basic details about the
PDF format and the development of its versions. The sub-chapter PDF/A – format for long-term
archiving deals with the basics of the PDF/A sub-format.
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INTEGRATION INTO STANDARD
APPLICATIONS
After installing Perfect PDF 12 and if you also checked the appropriate options for integration
with other programs (or left them checked), Perfect PDF 12 features are available in the
following applications directly through buttons and toolbars, without having to open the
program manually:


Windows Explorer



Microsoft Office applications

Setting up & Changing the Integration
The integration is carried out automatically during installation if the checkboxes for Windows
Explorer Integration and MS Office Integration have been activated in the setup dialog (which
has not yet been done in the following screenshot for clarification).

You can also change the status of the integration of the installed program at a later point in
time: In Windows 10, select Settings > Apps > Apps and Features, then in the list of installed
programs and apps, click on soft Xpansion Perfect PDF 12 and then click Change. In the soft
Xpansion Perfect PDF 12 Setup dialog, users can determine the integration by checking or
unchecking the corresponding boxes in the Windows Explorer Integration or MS Office
Integration command groups and following any further instructions.
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Note: Before you change the configuration, you should close all open applications, but, at a
minimum, those for which you want to change the integration settings.
The integration into the standard applications will allow you to create PDFs directly from other
files or from dynamic content and open the PDF program with just a few mouse clicks.

Windows Explorer (My Computer)
If the program is integrated into Windows Explorer, you can


convert different files into PDFs with just a few mouse clicks,



automatically open PDF files after conversion in the Perfect PDF 12 program, and



see the essential document properties and a preview of the PDF pages in a preview directly in
Windows Explorer.

Converting printable files to PDF with the context menu
Perfect PDF 12 can convert .txt, .html, .xps and image files into PDF format. No further
applications are required to do this. In addition, Microsoft Office file formats (Word, Excel,
PowerPoint) are supported in the context menu. These applications will need to be installed on
your computer.

In Windows Explorer, right-click one or more files that you want to convert. Then the context
menu for those file(s) will appear. If conversion of these file(s) is possible with the program, you
will see menu items that contain the label "Perfect PDF 12."
If menu entries for "Perfect PDF 12" are not available in the context menu, this might be for one
of two reasons:
The program is not integrated into Windows Explorer or is faulty because it was not (correctly)
set up during installation. In this case, run the installer again as described above at the beginning
of this section in order to modify the integration.
The second reason may be that you have selected a file that cannot be converted to PDF format.
The conversion to PDF is only possible if the files are printable, i.e. not for file archives with the
ZIP extension, program files (.exe), or video files.
Note: If Windows Explorer occasionally crashes after installing Perfect PDF 12, uncheck all the
boxes in the soft Xpansion Perfect PDF 12 Setup dialog of the installation. Then see if the
problem persists.

Converting One or More Files Individually to PDF
28

INTEGRATION INTO STANDARD APPLICATIONS

This command converts each source file into separate PDFs. After you have selected the
command, a window opens in which you can specify the details of the conversion. If you have
previously clicked or selected only one file, you will see the following window:

"Replace file extension with PDF” to create a PDF document from the selected file while
preserving the name and location (folder) of the original file,
"Add PDF file extension" keeps the file extension of the original file as part of the name and
adds "PDF" as a file type.
Alternatively, you can specify a completely different save location and name for the PDF after
clicking the three dots on the right side of the window.
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If the files to be converted are protected with a password, it must be entered here.
"Open PDF file with Perfect PDF" creates a PDF document from the selected file and opens it in
the Perfect PDF program, initially without creating a file. You can then edit it there and then
save it as a file.
Clicking on Import settings opens the dialog for defining the settings for the conversion to PDF.
The category of settings that matches the respective file type is automatically displayed in this
dialog.
If, on the other hand, you want to convert several files to PDF at once and you have therefore
previously selected them while holding down the CTRL key, the window looks a little different:

In the list above, the selected files are displayed for checking and you can deselect them as
necessary by unchecking the boxes. In this case, the PDF files created are placed in the same
folder as the original files.

Combining Files into a Single PDF
Of course, the command to combine multiple files into a single PDF is only available if you have
previously marked or selected more than one file in Windows Explorer.
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In the associated window, you can use the buttons on the right to specify the original files'
positions in the PDF, add more files or remove files from the list. The other four options are the
same as those explained above in "Convert one or more files to PDF one at a time" if you only
want to create a single PDF file.

Preview Window & PDF Properties
If the Preview Window option is activated on the View tab in Windows Explorer, a selected PDF
file is not only displayed there with the usual standard icon for PDFs, but also with a thumbnail
of the document pages on the right. However, this function is only supported starting with
Windows Vista.
A preview of all pages of the PDF file can then be viewed using the scroll bar on the right. The
preview image is scaled according to the size of the right window.
The integration of Perfect PDF 12 into Windows Explorer also adds an additional Perfect PDF 12
tab to the standard Properties dialog for all PDF files, which can be opened in the context menu
of the file. On the tab you can view the general properties of the PDF file at a glance.

Perfect PDF 12 as Default PDF Viewer and Editor
In Windows Explorer, you can specify for each file format which application should be used to
open a file by default, i.e. after being double-clicked. In order to set up Perfect PDF 12 to do
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this for all PDFs, proceed as follows: In the standard Properties dialog, which can be opened in
the context menu of a PDF file, click on the Change button and select the application from the
list. If you don't see Perfect PDF 12 there, in Windows 10, you can scroll down the apps list,
click More apps, then scroll down again and select Look for another app on this PC. In the
following dialog, navigate to the folder where Perfect PDF 12 is installed (by default C:\Program
Files (x86)\soft Xpansion\Perfect PDF 12), click on one of the two files whose names start with
"perfect -pdf-12” and then click Open. Then press Apply in the properties dialog.

Microsoft Office Applications
Perfect PDF 12 integrates with the Microsoft Office programs Word, Excel, PowerPoint, and
Outlook.

To do this, the installation program adds an additional Perfect PDF 12 group to the ribbon of
these Office applications if the integration has been activated in the corresponding installation
dialog. In addition, the file menu of the respective application receives the command Save as
PDF under Add-Ins. The Perfect PDF 12 toolbar is added to Microsoft Office programs without a
ribbon. Please consider the requirements that must be met for correct integration.

Save as PDF
The Save as PDF command converts open Microsoft Office documents to PDF and saves them as
a file and opens them in the Perfect PDF program or in the default PDF application. In addition,
detailed settings for the conversion to PDF (import settings) can be made here.
The integration and the Save as PDF command not only enable the rapid creation of PDF
documents and files, but also transfer metadata from Microsoft Office to the PDF document.
Metadata is information such as the table of contents including links, bookmarks, links, form
fields or comments. More information about the import of metadata can be found in the Import
Settings section.
If you click on Save as PDF", the following dialog is displayed where you can specify the storage
location and name for the PDF file.
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If Use document file path for PDF is on, the PDF document uses the same path (location) and
name as the source file being converted. However, the file extension will be “pdf.” If the radio
button below is activated, the file is saved in the folder that was used the last time a PDF file was
previously created. In addition, with this option you can always specify a completely different file
name and folder after clicking on the three dots to the right.
Check the first box in the dialog to open the document in the Perfect PDF 12 program.
If the box in front of "Open file in default PDF application" is checked, the PDF file will be
opened in the program set as the default PDF viewer and editor after saving.
The dialog contains an Import Settings button at the bottom left. This is covered below.
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Import Settings
A mouse click on the Import Settings button (a) directly in the Perfect PDF 12 ribbon group in
Office applications b) in the dialog that opens after you click on Save as PDF, or c) starting from
the Perfect PDF 12 context menu in Windows Explorer opens the dialog for managing the
detailed settings for creating PDFs. This is where you specify which properties from a source file
you want to transfer to the PDF file you're creating. This menu is also used to define the
properties a PDF file should generally have in addition to the specifics in the source file.
In the case of Word documents, for example, the properties of Office files include such helpful
elements as links or the table of contents.
Click on Import Settings and the following dialog window will open: The properties and settings
can be viewed and changed here.

Note: If you call up the import settings directly from the Office programs, you will only see the
settings for these applications and the PDF category, but not those for merging PDFs or for text,
HTML, image and XPS files shown in the screenshot above.
On the left you can view the categories or applications for which settings can be made. The
possible settings and values of the respective category are listed on the right and can be
changed there.

Word
The import settings for Microsoft Word files are the most comprehensive compared to most
other applications and file formats. In the Document section, you can set whether the general
descriptive properties (title, subject, author, keywords) from the PDF settings of the PDF printer
or from the Word document should be copied over to the PDF file.
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The Security Settings property determines whether and, if so, how a PDF file should be
encrypted:


Select Copy from PDF settings if you want the encryption level to be as defined in the virtual
printer's PDF settings.



If you select Protect if document is protected, then an additional line with a Security Settings
link will appear in the dialog. After clicking on the link, you can then define the relevant
settings here. These may differ from those that you would have simply copied using the
Copy from PDF settings option.

With Pages to convert, you determine which pages of the document will be converted to PDF:
all, the even or odd pages or a specific range of pages.
In the other options, the transfer for different metadata types is specified: links, table of
contents, fields, and comments. Check the boxes for the data you want to include. In Perfect
PDF 12, content controls from Microsoft Office 2013/2016/2019 form fields can also be
imported into the PDF. For example, see the Microsoft Office program help for detailed
information about content controls in Microsoft Word.
Under additional options, you can specify whether other elements of the Word document
should be copied.

Excel
In this category you will find the import settings for converting Excel spreadsheets into PDF files.
Most of the settings are similar to those for Word documents, with the appropriate adjustments
required for Excel spreadsheets instead of Word documents. Check the boxes for the data you
want to include.
Under other options, you can also specify whether the specific elements of the Excel document
(grid lines, row and column headers) should be included.

PowerPoint
In this category you will find the import settings for converting PowerPoint presentations into
PDF files.
Most of the settings are similar to those for Word documents, with the appropriate adjustments
required for PowerPoint presentations instead of Word documents. Check the boxes for the data
you want to include.
Under other options, you can also specify whether the specific elements of the PowerPoint
presentation (hidden slides, slide frames) should be included.

Outlook
This category summarizes the import settings and options for converting e-mail messages, tasks,
and other Outlook objects to PDF.
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Under "Emails and objects," you can specify whether the general descriptive properties (title,
subject, author, keywords) from the PDF settings or from the Outlook object (e.g. message or
task) should be copied into the PDF file. The Security Settings property is also available here and
determines whether and, if so, how a PDF file should be encrypted.
"Email or object format" defines the format from which the conversion to PDF should take
place. Under "Mail Attachments," you specify whether attachments attached to a message
should be ignored or embedded in the conversion to the PDF file. You can also specify whether
Microsoft Office files should also be converted to PDF before embedding and whether only file
attachments with specific extensions (file formats) should be embedded.
In addition, you determine how to proceed with the PDF creation with regard to the existing
text, the pages, and margins.

PDF
Here you specify those properties a PDF file should generally have in addition to the specifics in
the source file.
Three areas are available: "General properties" contains general descriptive properties (title,
subject, author, original application and keywords), which can also be found in the virtual printer
(PDF printer) in the group of the same name. The options for "Security properties" and in the
"PDF file" groups also correspond to those available with the virtual printer.
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PERFECT PDF 12 PROGRAM
The Perfect PDF 12 program is called up by clicking on its icon on the desktop or in the
Windows Start menu by scrolling down to the letter "P" and selecting Perfect PDF 12.
The program starts with an empty document window. You can create a new PDF
document (combine files, import, or create from scratch) or open an existing document. Multiple
document windows can be opened using the New Window command in the File menu. The
windows are completely independent of each other. After closing the last document window,
the program will also close. You can also end the program with the Close command. The File
menu is described in detail below.

PDF Reader Functionality
The PDF Reader is a basic part of Perfect PDF 12. The functionality of the Reader is combined
with other program functions and is always accessible. The document cannot be changed in the
Reader; it only offers functions for reading open PDFs. The following main functions are a part
of the Perfect PDF Reader:


Open PDF files, including encrypted files



View document properties



View the full content of the document, including comments, embedded files, images,
fonts used



Navigate through the pages (turning pages, scrolling, using links, etc.)



Enlarge and reduce pages (zoom function), view in full screen or read mode



Search



The values in form fields not only can be printed, but also saved with the document



Display and use tables of contents, outlines, bookmarks, links



View, change program settings within the available functionality



Expand product functionality through buying and activating new functions

The user interface in the Reader as well as in all other editions is the same as in Premium and
Business Edition. Menu items for disabled functions are either greyed out or when clicked a
message is displayed that this function is not available in the current Reader, trial or respective
purchased edition.
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User Interface
The main window or the user interface of the program has the following areas:

1) Backstage (File menu) – the area for file, print and product management. It is opened with a
click on "File."
2) Main menu (ribbon menu) – the main functional groups of the program. The ribbon is
intended to help you quickly find the commands required to solve various tasks. The ribbon
groups together related commands in and under tabs. They appear lined up next to each
other as if on a ribbon (hence "ribbon"). Each tab relates to a specific activity, essentially
working with a PDF document (viewing properties, editing or creating a new document),
navigating within it, and displaying the document in the program.
3) Quick access toolbar – a toolbar above the main menu for frequently used commands and
buttons. The quick access bar can be adapted by users to their individual requirements.
4) Workspace – the window in which an open document is displayed and can be edited.
5) Object window – to the left of the workspace. Depending on the program function, the
content of the object window varies, in other words, it's context sensitive. The individual
contents are explained in the corresponding section of this manual.
6) Status bar for additional controls and information elements – at the bottom of the main
window.
The description of how each area works is given in the corresponding section of this manual.

Hotkeys
The following hotkeys (keyboard shortcuts) can be used for certain important functions:
Keyboard shortcut

Function

Main menu
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F1

Access program help

Question mark icon at top
right

Ctrl+O

Open file

File > Open

Ctrl+S

Save file

File > Save

Alt+Ctrl+S

Save file as

File > Save as

Ctrl+F

Find

Navigation > Search

Ctrl + T

Text mode

Tools > Text

Ctrl+C

Copy to clipboard

Context dependent

Ctrl+V

Paste from clipboard

Context dependent

Ctrl+P

Print

File > Print

Ctrl+Home

Go to first page of document

--

Ctrl+End

Go to last page of document

--

Alt+F4

Close program

File > Close
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Workspace

On the right side of the program window is the workspace, where the open PDF document is
displayed. Usually, you only see one page or part of a page at a time. A scroll bar is available on
the right and bottom edge if the open document cannot be displayed completely on the screen
due to the level of zooming you've chosen. You can also use the arrow keys or the mouse wheel
to move around the document and move the visible portion of the document.

Object Window
The pages of a PDF document are made up of individual objects placed on the pages. Objects
offer a variety of information and, for most objects, you can adapt their properties to your
requirements. Object types in PDF files include text, images, bookmarks, comments, form fields,
layers, fonts, and embedded files.
You will find the object window to the left of the workspace. It also displays objects (e.g. layers)
or information (e.g. the name of the font used) that are not displayed on the document pages.
These objects and their settings and properties can also be modified in the window.
Depending on the object and the selected command, the object window sometimes contains
usage hints at the top. These texts will explain in varying degrees of detail which actions are
possible with an activated object, which tools are available, and what users need to do to use
them.
In addition to the information texts, depending on the object type, the objects present in the
PDF file and the command previously selected in the ribbon, the window also contains an object
list, an overview of the object properties and control elements. The control elements let you add,
delete or edit objects.
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The window shows detailed information about the respective object types. You can also find out
here which objects of each type are already in the PDF file displayed in the document window.
You can also change the object properties as well as add and remove objects.
You can hide the object window by clicking on the upright pushpin icon ( ) in the upper-right
corner of the window's title bar. It will then only be automatically displayed if you move the
mouse pointer to the visible name of the respective object type on the far left of the program
window. If you click on the horizontal pushpin symbol (
way, the object window will remain displayed.

) in an object window displayed in this

Object Window Options
Object window options are displayed by right-clicking in the object window. They contain
further commands for displaying the object window.

Hints
Hints are available in several sub modes. They help the user to understand the corresponding
function better and faster.
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If such a text is displayed, it contains textual information on inserting, editing or deleting the
respective objects.
Note: The text fields in Perfect PDF 12 have a fixed size. If the existing text is longer than the
size of the text field allows, please move the mouse pointer to the small downward-pointing
arrow in the bottom right corner. Then the complete hint text will be displayed.
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Object List

The object list shows the existing objects for the open PDF document, either as names in a tree
structure, as a list, or as a combination of names and icon images. For example, form fields are
represented as a list or bookmarks in a tree structure.
Select an object from the list by left clicking on its name. The name is then highlighted in color
as usual in Windows. For some object types (such as form fields), you can select multiple objects
by holding down the CTRL key while clicking. For example, if you click on a form field object in
the list, the corresponding form field is marked with a frame and, if necessary, handles in the
working area. You can hold down the CTRL key to make several markings.

Object Properties
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You usually only see the object properties (except, for example, in the program settings, because
there the entire program is the “object”) only after you have either


Clicked on "Edit" for already existing objects, or



Clicked on "Add" to add new objects and then decided on a specific object where
necessary

Most of the object properties and options are then displayed in a two-column table for the
object that is visible in the working area or for the new object. The (unchangeable) name of the
respective property is in the left-hand column and the specific characteristic (usually changeable)
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to the right. After a mouse click in a line, depending on the property, you can edit the property
in basically one of the following ways:


Text input



Press a toggle button to activate/deactivate the respective property or alternatively
double-click the corresponding line to change the status



Click on the small, downward-pointing arrow on the right to open a selection list or other
dialogs; only these properties will then be defined or changed

In addition, it may be that a property cannot be changed at all, so it will be deactivated. This is
the case, for example, when a document is protected against editing (encrypted).
For certain objects there are two buttons (“Apply” or “OK” and “Cancel”) in the lower area
which allow you to apply or discard the changes you've made. You can change the settings for
multiple properties one after another and then click Apply to apply all of the changes at once.

File Menu
In Perfect PDF 12, after opening the program window, the file menu is available on the far left.
The ribbon and its commands are then either to the right or underneath. The ribbon and file
menu are two essential parts of the user interface.
To open the menu, click on File.
Depending on whether a document is open in the program window or not, the File menu may
look different (see the following figures).
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No document opened

A document is opened

The File menu (Backstage) contains basic commands for working with PDF files, the program
settings, and information about the product. The latter include, among other things, information
and configuration options for your customer account, the status of your product activation, and
updates.
Note: The menu contains a few different commands depending on whether a PDF file is
currently open in the program or not. As long as no file is open, the commands Combine and
Create and Import can also be found there. Once a file is open, Save As, Export, and Print are
available from the File menu instead.
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Recently Viewed
Here you can see the history of the PDF files that you have recently opened or printed with the
program, listed chronologically and grouped according to specific dates (today, ..., this month).
Alternatively, the files can be listed with their name and complete path. Or only the storage
folder is documented or which files were printed with the virtual printer is displayed if "Save raw
data of the print jobs for further processing" is activated in the Printer Settings.
Note: Files or folders that were opened with the program but no longer exist (e.g. after deletion
or because they were temporary files that were viewed directly in a web browser) are grayed out
in the history.

Open (Ctrl+O)
This command opens the dialog for loading an existing PDF document from a PDF file into the
current window. Instead of first opening the File menu and then clicking on Open, you can just
press Ctrl+O on the keyboard.

Combine
With this command you create a new PDF document from two or more existing files. It will
combine them and open the new file in a new window.

Proceed as follows:
1. Press the "Add files" button and select the desired files. After clicking the down arrow in
the file types list box, you can see which file types can be combined (PDF, XPS, image,
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text, HTML, MS Office, EMF, SVG files). Hold down the CTRL key to select multiple files at
a time.
2. In the "Import settings" ribbon group for the file types specify which settings should be
used for the import
3. Create PDF using the Combine button. The combined PDF file appears in the workspace
on the right.
An alternative way to combine files is to select files in Windows Explorer and select "Combine
into a single PDF...".

PDF

Here you specify whether the elements mentioned in the dialog (table of contents, links, ...
JavaScript code) should be included in the combined PDF.
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Create and Import

With this command you create a new PDF document in the following ways (see also the
"Convert to PDF" tutorial on the support page of the soft Xpansion website):


Directly acquire from an external source (scanner, webcam)



Create completely new, empty pages



Convert images, text, HTML (website), Microsoft Office, eBook or XPS files

The creation of PDFs based on scanner and webcam comes with special properties:
Usual default settings for scanner and camera are available. The device-specific scanner
properties dialog can also be called up here. The process of acquiring data from the scanner or
camera for a newly created PDF file is controlled by the standard Windows settings. It cannot be
influenced by Perfect PDF 12.
For each import alternative there are special settings that define the individual properties of the
import, for example for text:
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Text & HTML
Import options for converting text files (plain text) and HTML files to PDF are available in this
category.

The Page and Borders properties define the format of the PDF pages and how wide the margins
should be.
The properties of the Plain Text group can only be applied to plain text.
These import settings are also used for eBook files.

Image
This category summarizes the options for converting image files to PDF. Among other things, the
widely used formats JPEG, TIFF, GIF, BMP and PNG can be converted.
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Resolution (DPI) allows you to vary the image resolution when importing the images into the PDF
format. The image will not be resized, but the page size can be adjusted to fit the image size.
Then the specified page size is ignored, and the page gets the size of the image plus the width
of the margins.
The format and width of the page margins for the PDF file can be specified in the Page and
Borders properties. The imported image is then always placed within the margins of the page.

XPS
This group contains the import options for converting XPS files to PDF. Check the boxes for the
elements you want to include.

Save (Ctrl+S)
The Ctrl+S key combination saves an opened and modified document to the original PDF file
without asking for further confirmation. If, however, you go to File > Save command, you will be
asked for the desired storage location before saving. The keyboard shortcut overwrites the file in
same location without asking. If no other previous version of the file is available, the Save
command opens the Save as dialog.

Save as (Alt+Ctrl+S)
This command allows you to save the open file under a new name and/or in a different folder. If
the file was newly created in the current program session or if no changes were made in it, the
File > Save command is not available, only File > Save as.

Export
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Various options are offered here for saving the pages of an open PDF file in other formats or for
exporting content from the file. In detail, the following is available:


Export pages and save to another PDF file



Split the document into several PDF files and specify a uniform file name prefix for all the
resulting PDFs



Convert the file into PDF/A formats (PDF/A-1 to PDF/A-4)



Export text from PDF to TXT format



Save pages as images (BMP, JPEG, PNG, TIFF formats) and specify a uniform file name
prefix for all PDFs



Save file in XPS format

Print (Ctrl+P)
This command opens the print window to start the print output of the open document on the
selected printer after the printer settings have been defined. Various settings and options for
printing can be specified in the window.

At the top, select the printer you wish to print to; otherwise the default printer set up in
Windows will be used for printing. This printer is usually a hardware device, but can also be a
virtual printer. The Perfect PDF 12 virtual printer is not shown because it cannot print to itself.
Click Printer Properties to set additional options for the selected printer. The settings offered
here are not provided by Perfect PDF 12, but are instead defined in the driver of the selected
printer.
Click on the large Print button to start printing.
Below this button are the print options offered by Perfect PDF 12:
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In the first options list box and the associated line below you can determine which pages are to
be printed (all, the current page, or a page range you specify).
You can also specify how many copies to print.
Collate/Don't Collate determines whether multiple copies should be sorted in the correct order.
Print on one side is the default option for specifying whether to print on the front and back of a
sheet. If the selected printer supports double-sided (duplex) printing, you can select one of the
two "Print on both sides" options and then print the PDF file on both sides of the paper, taking
into account the instructions in the printer manual.
If the selected printer does not support double-sided printing, you can use the "Manually print
on both sides" option in the drop-down list in Perfect PDF 12 instead. With this option, the
stack of paper must be manually removed from the print output and turned over to print the
back once the front has been printed. This is done when prompted by the program.
In addition, make sure that the paper size setting (A3, A4, A5, A6, etc., including options for
borderless printing, among others) is sufficient to print the document pages as desired and that
the paper orientation (portrait or landscape) is correct. With borderless printing, pages are
printed to the edge of the sheet. If the corresponding options are not used, the page will be
positioned on the sheet slightly offset by the width of the printer margins and, if necessary,
reduced.
The page scaling options before printing can be used to enlarge, reduce or split the pages:


Print in original size: Here each page is printed starting from the upper left area without
adjustment to the paper size. Areas that do not fit on the paper will not be printed.



Reduce page to fit: Here the page is reduced so that it fits completely on the currently
selected paper format



Fit page on sheet: This is where the page is reduced or enlarged so that it completely fits or
fills the currently selected paper size



Reduce page to printable area: Here the page is reduced so that it fits completely in the
printable area of the currently selected (smaller) paper format



Fit page to printable area: Here the page is reduced or enlarged so that it completely fits or
fills the printable area of the currently selected paper size

Print page centered: automatically places the pages in the center of the sheet. Use the toggle
button to enable/disable this option.
If you activate the "Adjust page orientation" option, the program automatically determines the
optimal orientation for the document pages. The orientation set in the options above (Portrait or
Landscape) is then ignored.
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The print window also includes a preview area on the right showing the effects of the different
options. At the very bottom, it provides a control to select the page being previewed. Click in
the field and enter the desired page number directly using the keyboard or use the two arrow
keys next to the field to flip through the preview page by page. To the right of this is the total
scope of the document ("of...pages").

Close (Alt+F4)
This command closes the corresponding document window. If changes have been made in the
open file that have not yet been saved, the program will suggest you save them. Other open
document windows will remain open. This command has the same effect as the X at the top
right of the program window.

Compare PDF Documents
Perfect PDF12 enables you to compare two PDF documents and mark the differences. Go to
“File Menu” and select “Compare PDF Documents”, you will then see the following menu:

There are two functional groups for the selection of files: “Original document” and “Modified
document”. You open both documents, press “Compare documents” in the middle group and
see the differences as marked phrases. Press one of the two “Save” buttons to save the first or
the second file with the marked differences.

By using “Options,” you define the settings for the compare process and for the presentation of
its results.
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Find in Files (Search)
Perfect PDF 12 offers a search function for words, sentences, and phrases. You can specify
which locations to search (folders and subfolders), what file formats to search, whether to
include embedded and password-protected files, and additional options (such as case sensitivity).

New Window
This command opens another program window. The windows are completely independent of
each other and are available separately in the Windows taskbar. After closing the last document
window, the program will also close.

Settings
The basic program settings (e.g. design of the user interface, defaults for the display of PDF
pages and files, regional settings and units of measurement, standard user data, handling of
links, comments and forms in open files) are found here. You can view these settings and adjust
them if necessary. After starting the program, open File > Settings.
You will then see the available categories of settings listed on the left. On the right, the Object
Properties table shows the options available in the selected category. Once made, settings
remain active until changed.
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The settings can also be called up via the gear and person symbols on the right end of the
ribbon:

Note: In the program you can also call up the user guide (program help) at this point by clicking
on the question mark symbol.

Style & Viewer
The Style option changes the design of the entire user interface. This means its color, with two
lighter and two darker styles available to choose from.
The Page Layout area offers several separate options to define how the pages of opened PDF
files are displayed in the program window: The selection list for Zoom determines whether the
document is opened in its original size or whether the original page size is enlarged or reduced
to fit into the program window. Rotate Page lets you select how many degrees the page will
rotate when you click that button (0 means that no rotation is allowed). Columns allow the
pages to be displayed in a maximum of four columns. Turn on Horizontal Page Layout to tile
document pages horizontally in multi-page documents. The last option in this group "Use page
layout from document if available" uses layout settings stored in the PDF document.
The two Viewer options determine how embedded files should be opened.
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The options under Rendering define how the program should load (draw or calculate) the PDF
pages in order to display them: the Page Cache drop-down list determines whether and, if so, to
what extent the program uses the cache for loading. The more cache that can be used, the
faster the display will be. Text rendering: specifies the method for rendering text. With Image
Interpolation, you determine whether and, if so, with which calculation method, the quality
(sharpness or resolution) of the images in the PDF document should ultimately be reduced in
order to achieve faster display of the PDF pages. Depending on the process, varying degrees of
image information can be lost during reduction, so the loss of quality also varies. Use the
Blending Mode button to toggle it on or off in a presentation. The last rendering option is "Use
embedded color profiles." If activated, the profiles embedded in the PDF document are used,
which can slow down the loading process, but this will also improve the color fidelity of the
display.

User & Region
From the Language list, select the language for the user interface that will be displayed the next
time you start the program. The Country, Time Zone, and Units of Measure lists provide
additional regional settings. The Units of Measure option changes the units (points, millimeters,
centimeters, inches) used by default in the program when specifying measurements.
This category also allows you to specify the default values for users' names, organization, email
address, and location.

Program
Allow Internet Links recognizes that clicking on an internet link poses a potential risk. Malicious
websites can deliver harmful content to your computer or secretly collect data. If you want to
eliminate these risks, you can leave this option unchecked so that web links in the PDF
document are not followed.
"Allow external links to files on this PC:” If this option is enabled, a link to an external file on the
computer will be followed. "External" means that targets (files) can be linked outside of the PDF
file and these files will be opened if an application is installed that can open the file.

Forms & Annotations
For PDF forms, you can specify whether forms are fillable by default and whether form fields
should be highlighted.
"Enable sending of form data over the internet" recognizes that malicious scripts in PDF forms
can sometimes send form data over the internet in the background. If you assume that this is
not a major risk for you and need to enable form data to be sent, you can activate this option.
"Show annotations:" If this option is activated, the annotations are displayed in reader mode.

Product
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Here you can see information and configuration options for your customer account, the status
of your product activation, search for updates, and identify the product edition and version you
have installed. Among other things, you can log into your account directly from Perfect PDF 12,
create or change an account, manage your activation and existing subscriptions, check for and
apply updates, or update/upgrade product functionality.

Customer Account

Here you can log into your existing account directly, connect the program to the account or
create another account. Another email address can also be linked to the account.

Unlock Product

If you want to upgrade your product with new features or manage your subscription, then this
section is for you. Here you can also convert a trial or free version to a paid version.

Program Update

Here you check whether an update is available and start the update process if one is found. The
automatic update notification or search can also be switched on and off here.

About the Program

58

PERFECT PDF 12 PROGRAM

The version number and copyright information for the installed product are displayed here as
well as links to the user account for extending product functionality and technical support.

Menu: Document
This tab is only visible when a document is open in Perfect PDF 12. It contains the commands
for working with the opened PDF document. These refer to the objects and content that a PDF
document can contain and make up its structure. Use the appropriate commands on the
Document tab to view the properties of the opened PDF and/or edit the file's objects and
content.
Elsewhere in these instructions (PDF Document), you will find detailed information about the
possible objects, content, and structure in a PDF file as well as their display and editing options.

General
In Perfect PDF 12, you can find these properties after clicking General on the left of the
Document tab. The technical specifications for saving a PDF document as a file are defined here:
PDF version and which optimization to use online. This information is either specified by the
author of the document or it is automatically assigned.

Description
In Perfect PDF 12, you can find these properties after clicking General on the left of the
Document tab. The properties that are used to identify a document and to catalog and search it
in external databases are included here. These include, among other things, the document ID,
revision number, dates (which are assigned automatically), along with the title, subject, author,
keywords, original application, and the application with which the PDF file was created. At least
the title of the document should be given. This information is also either specified by the author
of the document or it is automatically assigned.

Custom Properties
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User-defined information about the document can be entered here by hand. After clicking in the
field to the right of Add Property, the name of the property is shown. Then click on the blue
cross at the end of the field. In the third step, the specific characteristics of the property are
specified. Clicking on the red cross at the end of a line deletes the custom property.

Metadata
In Perfect PDF 12, you can find and work with the metadata stored in the document after
clicking the General on the left of the Document tab. Metadata describes the characteristics or
properties of a document and extends basic document properties. It allows documents to be
used even more efficiently. Metadata makes documents easier to use in applications, even if
those applications do not know the original file format of the document. Metadata can also
significantly increase the value of collaborating on documents as part of production processes.
For example, an image file may contain metadata such as a working title, description, thumbnail
or intellectual property information.
In order for different applications to actually be able to use metadata, there must be a common
standard that all applications understand. The Extensible Metadata Platform (XMP) provides such
a standard. XMP-encoded and XML-formatted data supports a wide variety of workflows and
tool environments. Localization is possible and Unicode is supported. This information is either
specified by the author of the document or it is automatically assigned.
Here you can load the metadata from XML files, export it to XML or transfer it from the PDF
document.
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Protection & Rights
This is where the rules for protecting the PDF
document and access to its contents are set:
encryption method and degree of encryption
(algorithm, key length), owner and user
passwords, access rights (see also the "Protect
PDF" tutorial on the support page of the soft
Xpansion website).
The owner password should be assigned to
users who will need to access the document
without restrictions, including the ability to
change rights, encryption, and passwords.
The user password is intended for users who
can have access to the document to the extent
set by its owner (often the author). A user can
open a document protected with a user
password, but cannot set or change any rights,
encryption, or passwords. If the document has
been encrypted but no user password has been
set, any user can open and edit the document without having to enter a password. However,
their access rights are restricted to the extent specified by the owner.
Eight kinds of access rights can be granted or denied for the PDF format in order to control how
users interact with the document: printing, copying and removing content, filling out form
fields, and making changes to the document (including editing the structure or content and
adding, removing or changing annotations).

Digital Signatures
In Perfect PDF 12, one can digitally sign PDF documents by selecting Digital Signatures > Add
Signature. A wizard then guides you through the signing process step-by-step (see also the
"Digital Signature" tutorial on the support page of the soft Xpansion website). The following
steps are carried out:
1) Define signature field & set position, i.e. where the signature should be placed if the
signature is supposed to be visible (see Step 2).
2) Set whether the signature should be visible.
3) Create a graphic representation for a visible signature: draw with the pen or select an
image. A signature text can also be added. You can set the usual properties for
handwritten signatures and for the text: color, line thickness, font, size, etc. A preview is
also possible.
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4) In the next step, one defines the important properties:


The certificate



Signature format: PAdES, PKCS#7, X509



Hash function format: SHA256, SHA384, SHA512, SHA1



Action: what to allow as changes



Further technical settings

5) Additional information: reason for signature, location, contact
When you select "Sign and save," the document is then digitally signed and saved in the
specified location.
Clicking on a signature in the list shows the key properties of this signature. Once the document
is signed, the properties can no longer be edited.
A timestamp can also be added.

Page Editor
Although PDF was originally developed as a format to save electronic documents without much
possibility of modification, Perfect PDF 12 offers a wide range of functions for editing page
content (text and text properties, images and graphic elements), adding and removing entire
pages, and change their sequence, size, and much more.
The commands for managing, designing, and editing pages and page content can be found in
Perfect PDF 12 under Document > Pages.

Manage Pages

After clicking on Manage, thumbnails for each page including the page name are displayed in
the right part of the program window. Here you can select one or more pages for editing:
individual pages with a single mouse click, all pages, only even pages, any number of pages with
the CTRL or SHIFT key pressed plus mouse clicks according to the Windows standard. In
addition, a selection made can be completely withdrawn or reversed. Editing complete pages
means, among other things: inserting new pages (blank pages, pages from other PDF files, or via
scanner and camera), exporting pages to another PDF file, changing the position of a page
within the document, deleting, rotating, resizing or cropping pages, or changing their
numbering.
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The two functions "Size and Orientation" and "Crop Pages" allow you to make any changes for
complete pages: paper selection, portrait and landscape orientation, set custom size, rotate
pages, etc. both for single pages and for the selected several pages at once.
For details on exporting, cropping and deleting pages, refer to the tutorials "Split PDF Files" and
"Delete PDF Page" on the support page of the soft Xpansion website.
To undo changes made in the document, use the Undo button.
Note: The "Undo" command is only available after changes as long as you have not exited the
corresponding tool (here the one for managing pages). After closing the tool and opening it
again, previously made changes can no longer be revoked with that command!
Click Close on the far left of the ribbon to exit the PDF page management tool.

Design Pages
Commands for adding backgrounds, watermarks, stamps, headers, and footers are grouped
here. Layers can also be added here.
After you have completed a new element, click Create in the ribbon at the top left. Click on
Cancel to exit the design tool without creating a new element.
Note: To remove a design element, use the page editor found under "Edit content" (see below).

Edit Page Content

Select Content Items
To edit specific content object, you need to select it in the object list or click on it in the
workspace. If you select a group or the whole page in the working area, you will get a list of
related elements in the object window on the left. When there is more than one item in the list
on a page, you can also use the up and down arrow keys to move between objects after clicking
on an object name in the list. You can also click on the object name to select it for editing within
the workspace, i.e. to mark it with a frame. Several objects can also be selected at the same time
in the object list. To do this, hold down the Ctrl or Shift key while clicking an object. This is the
standard Windows procedure for selecting multiple items. You can also select several elements
in the program's workspace. Press and hold the left mouse button while moving the mouse to
open a rectangle to enclose the objects to be marked. Starting from the point (upper left corner
of the rectangle), move the mouse down until you have selected all the desired objects and thus
reached the lower right corner of the opened rectangle. Then release the mouse button. All
elements that fall within the rectangle, whether fully or partially, are then marked as selected.
The marked objects are highlighted in the object list and in the workspace. In the workspace,
this is a frame with dashed lines and within this frame with a brick pattern.
It can happen that the selection and marking of the desired element in the working area seems
difficult at first. For example, if a compound object is already selected and you want to select
one of its child objects or if another object is overlaying the object you want to select.
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General Actions for Content Elements
Adding new elements on a page or actions on elements is done after clicking the Edit Content
button with commands under the Manage tab (see the "PDF Editor" tutorial on the support
page of the soft Xpansion website).

Some of the commands are only available for a single item at a time, such as editing a block of
text or editing shape objects. Other commands (such as Group) are only available when more
than a single object is selected. Commands that are not available are grayed out. This way you
can immediately see which commands are available for selected objects.
The colored frame that encloses a selected object in the workspace is called the marking in the
program. It enables various actions with the marked object.
The marking around an object is visible after clicking on it with the left mouse button. After that,
you can move the object on the active page by pressing the left mouse button again and, while
holding down the mouse button, move the mouse pointer to the desired position. When you
release the mouse button, the object will take its new position.
Note: In Windows tablet mode, the icons CTRL and SHFT on the status bar must be used as a
substitute for the Ctrl and Shift keys.
The size of the marked object can be changed with the blue handles on the frame lines. To
change the size with one of the handles and at the same time retain the proportions, press and
hold down the Ctrl key in addition to the left mouse button while dragging the mouse. If you
press Shift instead of Ctrl-, the object's center is maintained, and all 4 edges are moved at the
same time.
The start or end point of a line or an arrow object can also be moved. To do this, use a red,
square handle.
When inserting a new shape object, the position and size of the object can also be specified
using the marking. In the case of lines and arrows, you can obtain objects that run exactly
horizontally or vertically if you hold down the Ctrl key while dragging the mouse in the
corresponding direction. When inserting other shape objects, pressing the Ctrl key at the same
time serves to place objects with equal horizontal and vertical dimensions (e.g. a square or
circle).
A marked object can also be rotated. To do this, click with the left mouse button on the circular,
green pivot point at the upper end of the marking frame and keep the mouse button pressed
while you move the mouse pointer. When you release the mouse button, the object remains in
its current position.
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Double-clicking a text object activates the internal text editor for editing and formatting the
text block.
If several objects are marked, they can be aligned to the left or right of an object in the group of
marked objects or centered. The object to which the others are aligned has a darker (denser)
marking pattern than the objects being aligned. By default, it is the object that was last selected
(highlighted) using the Ctrl key.
You can change the object you want the others to align to. To do this, click on it in the group of
marked objects. Its marking pattern will become darker and denser. You then use the Alignment
commands to specify how the objects are to be aligned.
As already mentioned, Perfect PDF 12 offers a variety of functions for editing the page
content.
Note: The automatic adjustment of the page content layout (including page breaks), for
example after adding or deleting text or images as in Microsoft Word, where documents do not
have a fixed layout, is not possible.
This is because the PDF format is based on the principle of a fixed layout, also known as
WYSIWYG (what you see is what you get). This is the foundation of PDF, as it was originally
developed to provide a format in which to store electronic documents with little modifiability
and a fixed layout.
A PDF document always consists of a fixed number of pages, unless the user actively adds or
deletes pages (see "Manage" above). As part of the layout, all page content elements in the PDF
always remain in exactly the same position after opening, regardless of the devices used for
viewing and printing.
The appearance of the pages is determined by a sequence of graphic elements (combination of
text, graphics and images) placed on them. It is fully fixed, which means that all layout and
formatting information comes from the application in which the pages were created.
When converting documents from other formats with a fixed layout (e.g. XPS) to PDF, Perfect
PDF 12 immediately transforms the original objects into PDF.
To convert documents with a non-fixed layout (e.g. plain text, RTF text or HTML), the original
content is divided into a fixed number of pages of a certain size. The content of each page is
given a fixed layout.
Under Document > Edit content, you will see the commands for inserting and editing page
content.
To undo changes made in the document, use the Undo button.
Note: The "Undo" command is only available after changes as long as you have not exited the
corresponding tool (here the one for editing page content). After closing the tool and opening it
again, previously made changes can no longer be revoked with that command!
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Insert

With the commands from this group, you can insert content objects on the active page. This can
be formatted blocks of text, AutoText objects, raster images, or vector objects from the shapes
gallery. If a command from the Insert group is selected, the inserted object can be edited
immediately.
AutoText objects are standard components with specific values that are assigned automatically.
Perfect PDF 12 has the following components: page number, page name, document title,
subject, author, name, time, and date. In the text field you can combine plain text with auto
text, for example
Page: {page number} of {total number of pages}
The result on document page 3 of a twelve-page document is then "Page 3 of 12" and is
displayed in the workspace.
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Font
The next group contains commands for text formatting: types, sizes, and styles (e.g. bold, italic,
underline) for fonts, and color, among others. Note that a text object must be selected on the
active page to use these formatting commands.

Paragraph
Here you will find the commands for paragraph formatting: shading, border, alignment, line
spacing, and line break. Note that a paragraph object must be selected on the active page to use
these formatting commands.

Form
This group contains actions for formatting shape objects: fill commands, border and line
properties. Note that a form object must be selected on the active page to use these commands.

Object
The commands in this group are intended for grouping objects and clipping content objects.
Note that you must have one or more objects selected on the active page before you can use
these commands.

Z Arrangement
This group contains commands for aligning and arranging content objects. For example, you can
change the order in which objects lie on top of each other, i.e. vary the Z arrangement. Note
that you must have one or more objects selected on the active page before you can use these
commands.

Orientation
After marking several objects, you have the option of aligning them left, middle, right, top or
bottom, in each case in relation to an object defined as the "leader" to which all the other
objects align. The leader is the object highlighted in blue, i.e. the object to which the other
objects are aligned:

In this example, this is the third line within the marking.

Adjust Size
After marking several objects, you have the option of adjusting their width, height, or both in
relation to an object defined as the "leader."
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As in the previous section on alignment, a leader is the object whose size is taken as the default
reference value.

Layers
Layers are added with the Layer function in the Document > Design menu. You can either
(create) layers directly from scratch, use an existing PDF document as a layer, or assign one of
the other elements listed in the Create menu as a layer.

In both cases, the properties area of the object window is displayed where you can define the
properties of a new layer.
You can see the layers in a PDF document in Perfect PDF 12 by clicking Document > Pages >
Layers.
Note: If a document does not contain any layers, the button is grayed out. If at least one level is
available, commands for managing the level(s) are available after clicking on Levels.
The layers are displayed in the object window as optional visible content in the form of a tree:

In the ribbon, you can use two buttons to select whether you want to define the visibility or
block existing layers. After you have decided on one of the two properties with a mouse click,
check the respective box if you want the layer to be visible. The procedure for blocking levels is
the same. Click on the boxes to toggle between the two states.
Note: The additional commands for adding layers are not available after clicking on the Layers
button in the ribbon, but after selecting the appropriate element (background, header/footer,
etc.) in the Design ribbon menu.
For example, if you want to insert a background as a layer, click on Document > Design >
Background to define it and give it a name. After clicking on Apply, the new layer will be
created.
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Layers can be deleted if there is no reference to it in the document. This is the reason why there
is no separate Delete Layer function in the program. Layers can be deleted using the Optimize
tool instead. The Perfect PDF program will automatically check whether layers can be removed
without problems.

Annotations & Forms
Annotations
You can see all comments on a document page in Perfect PDF 12 by clicking on Document >
Annotations and Form Fields > Annotations. Commands for inserting and editing annotations
can also be found there.
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New annotation objects can be inserted using the Add command. Annotations are selected
either directly in the workspace or in the object window.
Note: For pencil drawing the Windows setting “Allow my pen to act as mouse in legacy
options” is to be set.
To undo changes made in the document with the Annotations tool, you can use the Undo
button.
Note: The "Undo" command is only available after changes as long as you have not exited the
corresponding tool (here the one for adding and editing annotations). After closing the tool and
opening it again, previously made changes can no longer be revoked with that command!

Forms
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This functionality allows you to create and edit form fields (see also the tutorial "Create PDF
form" on the support page of the soft Xpansion website).
New fields can be added using the Add command in the ribbon. After clicking on Edit, the
properties for a previously selected field can be viewed and changed. Click Remove on the
ribbon to delete a field or group of fields.
Existing form field objects can also be edited after you have clicked on them using the
commands in the Order, Alignment, and Resize ribbon groups. To select multiple objects, hold
down CTRL while clicking. For example, you can use the Order command to change the order in
which the cursor moves across form fields when you press Tab.
Note that you must have selected a form field object (for the Order command) or multiple
objects (for Alignment and Resize) on the active PDF page before you can use these commands.
If not checked, the commands are grayed out.
The form fields in the document are listed in the object window. Each field has a name that is
unique to the document. Depending on the selection made in Display Options, different form
fields or individual properties will be displayed.
Editing functions for fields also includes linking them to events, actions and scripts. You can find
out what options are available in the section below.
Use the Field Design (Standard) button to set the most important design properties for new
fields as the standard. The settings made here only apply to the fields that you create after the
respective definition. You can always change existing fields by clicking on the Edit button.
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Events, Actions, and Scripts
In Perfect PDF 12, events, actions, and scripts are inserted and edited in PDFs under Document
> Annotations & Form Fields > Events and Scripts.
In order to determine the object type (document, pages,
form fields, annotations) for which the events, actions, and
scripts should be defined, select the desired object in the list
box at the top. PDF Events – Document is the default.
Depending on the object selected in the first list box, there
are different and varying numbers of options (suitable for
the object) available below.
To add an action to the open PDF file, click Document >
Events and Scripts and then click Manage > Add. The group
also contains the commands for editing and deleting
actions.

The following actions are available:


Open page (optionally including "jumping" to specific locations within the page, to an area
or to a bookmark on the page)



Go to web address or compose an email message



Open file (PDF format, destination can be a page or a bookmark)



Open embedded file (PDF format)



Execute/start application (program).



Show/hide annotations, fields or layers



Reset form (empty form data)



Submit form data (by email or over the web)



Import form data from file



Execute command



Execute JavaScript (including inserting and editing JS code)

JavaScript code can be accessed and executed by actions associated with bookmarks, links,
pages, and document events. You can also use JavaScript in PDF forms. The most common use
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of code in forms is to format data, perform calculations, validate data, and assign actions. For
example, scripts linked to form fields can be started when a button is pressed.
In addition to executing and inserting existing JavaScript files, Perfect PDF 12 also offers the
option of creating and editing JavaScript code directly in the program in an editor window. To
see these functions, select Document > Events and Scripts > JavaScript Document in the top list
box on the tab. These functions are usually only required by software developers.

Embedded Objects
Fonts
The list of fonts embedded and used in the PDF document, as well as detailed information about
each font, can be seen in Perfect PDF 12 by clicking Documents> Embedded Objects > Fonts.
Embedded fonts are marked with a green vertical line; non-embedded ones with a yellow line. If
the font is not embedded, the program uses a locally available system font (font substitution) to
display the document text or to enable printing.
You can find the name of the font used for the
replacement in the object properties in the
"Font used" line. If there is a number in an
orange circle next to the font name, it means
that a font exists more than once in the
document.

Images
In Perfect PDF 12, you can see the list of
images present in the PDF document and
information about each image by clicking on Document > Embedded Objects > Images.
With the Images object type, you can see the list of raster images in the PDF document or
thumbnails of these images in the object window. Further information about the individual
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images can be obtained via the Tools/Selection/Images menu after clicking on the images in the
workspace.
Each image can be copied to the clipboard or saved.
Image compression, changing color space, and reducing the image quality can be done by going
to Tools > Optimize/Document.

Files
You can see the list of embedded files in Perfect PDF 12 by clicking on Document > Embedded
Objects > Files. Commands for embedding, removing, and exporting files are also found there.

With the object type Files, the list of files embedded in the PDF document is displayed in the
object window.
New files can be embedded with Manage > Add.
The embedded files can be exported or removed. PDF files can be opened in a new window
using the Open command in Perfect PDF 12.
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Menu: Navigation
The buttons on this tab take you to the commands for using and managing (editing) the
navigation options available in the document.

Navigation
In this group, click on the Pages icon to see small thumbnails of the document pages on the left
side of the object window. Then click on one of the page views to see the corresponding page
on the right side of the workspace. Outline displays the document's table of contents (if
available) in the object window. A mouse click on a heading of the directory shows the linked
document page in the working area. The Find command (Ctrl+F) allows you to find text in the
document.

Manage
In this group, click the Bookmarks, Links, and Outline icons to edit, delete, or add items to the
respective objects.
New structure elements (bookmarks) can be inserted directly by clicking on Manage >
Bookmarks:

To insert a new bookmark, first enter a name in the text field on the left. Click on the "+"
symbol to add the newly specified bookmark name to the list. A page, coordinates or area on a
page is then specified as the target. The magnifying glass can be used to search for bookmarks.
A bookmark can be modified after clicking on it and then choosing the Edit command.
Click Remove to delete a bookmark.
The table of contents of a PDF document can be edited after clicking the Manage > Outline
button. The current index is displayed, for example:
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The buttons in the Manage group allow you to edit each index entry, add new ones, delete
existing ones, move up/down, promote or demote.

Menu: View
On this tab you will find commands for defining how the page of the opened PDF document
displays in the program. This includes zoom options, but also different document views and
reading modes. You can also save the settings made for displaying pages here.

Customize
Here you can adjust the zoom factor and thus the display size of the PDF document with a
mouse click so that the respective target display is achieved:
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"Original size" sets the value for the display size to 100%



"Width" sets the display size so that you see the document pages in their entire width (from
the left to the right edge in the workspace).



"Height" sets the display size so that you can see the full height of the document pages
(from top to bottom).



"Whole Page" sets the display size so that you see the document pages in their entire height
and width, i.e. the entire page

Zoom


Zoom allows you to select a preset value



"Zoom in" and "Zoom out" changes the zoom factor by a fixed value with each click on the
button, which can vary depending on the factor set



"100%" sets the value for the display size to 100%

Alternatively, you can use the slider in the status bar to zoom.

View
The first command in this group displays multi-page documents in one or more (2 to 4) columns.
The other two commands rotate the pages either 90 degrees to the right or to the left. If a PDF
document consists of more than two pages and a multi-column view is also selected, you can
display the first page separately in the first cell by selecting the Title Page option.
Note: Rotating the pages on the View tab only changes how the pages are displayed, not their
actual orientation in the document. If you want to change the orientation in the document,
select Pages > Document > Manage and follow the explanation that is displayed.

Read Mode
In this group you can choose between three document views.

Full Screen
In this view, the user interface elements are completely hidden (ribbon, status bar and borders of
the program window are not visible). Full screen corresponds to the corresponding view in other
programs. The program window fills the entire screen. You can scroll through the document
using the usual standard functions: Page Up/Page Down, mouse wheel, and arrow keys. Links in
the document can also be used. To leave full screen, simply press ESC.

Reading Mode
In reading mode, only the current page is displayed, just like in a book. Scrolling is done using
controls on the status bar.
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Horizontal Page Layout
Choose this view to tile the document pages horizontally in multi-page documents.

Page Display (Keep It)
If you click on this button, the currently defined page layout is saved. It will then be the same for
all documents that you open in the program.

Menu: Tools
This tab is only visible when a document is open in Perfect PDF 12.

Viewer Tools
Two viewer tools are available: snapshot and magnifying glass. Using them will not change (edit)
the content placed on a page.
With the snapshot tool, you select an area on the page to copy it to the Windows clipboard (for
direct pasting into other programs) or save it as a separate image file. To define the area, click
on the square handles on the frame and drag them, or use the mouse to draw the area you
want from scratch.
Use the magnifying glass to enlarge a page area on the left in the object window. Use the slider
above the enlarged area to set the zoom factor. As with the snapshot, you can both define the
area you want to zoom in with the frame or the mouse. Copying the enlarged area to the
Windows clipboard or saving it as a separate image file is possible as well.

Select
There are two modes: text selection and image selection. The selection is made in the working
area: text selection by dragging the mouse while holding down the left mouse button; images
are selected with a mouse click.
If a text or an image is selected, it can either be copied to the clipboard or saved as a text or
image file.

Optimize PDF Document
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After clicking on the Optimize/Document button, a large number of properties are available that
can be optimized for the opened PDF document. The following objects can be modified
automatically to achieve certain optimizations (file size, opening speed, display, etc.) or
improvements:
1) Images: Multicolor or monochrome images and grayscale images can be optimized
separately. For example, you can reduce the number of colors, change the compression,
or reduce the quality and scale (downsampling). When downsampling, a threshold is
queried: Small images whose dimensions are less than width * height in pixels are not
downsampled. The changes are applied to all images in the document.
2) Fonts: You can specify here whether fonts should be embedded and, if so, which ones. It
is advisable to embed as many, if not all, of the fonts. This will ensure that the PDFs can
also be read as intended on computers which do not otherwise have the fonts available.
3) Clean up document content: Delete broken links, bookmarks, outline elements and form
fields, remove page thumbnails, delete specific types of comments, delete or flatten
specific layers. Metadata, embedded files, actions, and a lot more can also be deleted, i.e.
removed from the PDF document.
4) Various compressions can be made.
After selecting the changes you want, click the Start Optimization button to apply those settings.
Important note: If objects were changed and the document was then saved, the changes made
cannot be undone.

Text Recognition (OCR)
The free OCR engine Tesseract from Google is used for text recognition.
Text recognition is applied to scanned pages as well as any images in the document. After the
"Start" button has been pressed, the text recognition begins, its progress is documented by an
animation and at the end you receive a message about the recognition result. If the recognition
was successful, you have the option of selecting the recognized text and then copying it to the
clipboard or saving it as a text file. If you want to do this, click on "Text" in the "Select" ribbon
group of the "Tools" menu, select (highlight) it with the mouse and then choose "Copy to
clipboard" or "Save as".
To save the complete text recognized and saved as invisible content to a text file at once, use the
"Export/Export Plain Text" function from the "File" menu. Note that the feature requires you to
uncheck the "Skip Hidden Text" option for the recognized text to be exported.
Neither the manufacturer of Perfect PDF 12 nor its publishers and distributors are responsible
for the recognition quality.

Status Bar
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The status bar is located at the bottom of the program window.

The CTRL and SHIFT buttons can only be used on a tablet or with a touch screen when it is
necessary to perform certain actions that would be done on a keyboard with the "Ctrl" or
"Shift" keys: mouse or finger grabs pull, etc.
Use the arrow keys in the status bar to scroll through multi-page documents. And to directly
display a specific document page, click in the field between the arrow keys (<currently displayed
page>/<total document page number>), type in the desired page number and press the ENTER
key.
On the status bar on the right you will find buttons for changing the zoom factor for the open
document. Click on the percentage to select one of the given numbers. You can also change the
display very quickly with the slider or click the plus and minus signs to change the zoom factor.
On the View tab in the ribbon, in the Fit and Zoom groups, commands are also available to
enlarge or reduce the display of the pages.
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